iOS SDK migration (SDK11)

문제점

만든지 1년도 안된 아이폰 앱을 간단하게 화면만 수정하려고 하였으나 기존 앱의 SDK 버전이 낮은 관계로 SDK 버전을 올려야 하는 심각한 상황이 발생 (SDK? )

 

구버전 앱의 SDK version: iOS 10 / swift version 2.4

새버전 앱의 SDK version: iOS 11 / swift version 3.2

 

해결과정

1. 경험많은 swift 개발자 코드 리뷰

2. 시간 산정 및 승인

3. Migration 및 화면 수정

4. 앱등록

 

소요시간: 40시간

Reference: 612

 

많은 고객들이 의아해 하는 점이 나는 정말 간단한 기능을 수정하는데 왜 SDK라는 것을 업그레이드하여야 하는냐하는 점입니다. 하지만 이것은 애플의 정책으로 인해 발생하는 문제로 그 누구도 피할수 없는 문제입니다. 아래 링크에서 애플의 iOS SDK 11에 대한 공식 발표를 참고하세요.

애플 공식 iOS 11 관련 발표

IOS SDK Announcement

 

 

앱수정은 앱닥터

Next PostANDROID 8 PUSH NOTI 에러